Qui peut m'expliquer le fonctionnement de Open Referer Control ? [RESOLU]

Accueil Forums Section Logiciels Problèmes / Questions & Avis Logiciels Qui peut m'expliquer le fonctionnement de Open Referer Control ? [RESOLU]

Ce sujet a 28 réponses, 3 participants et a été mis à jour par Avatar AZAMOS, il y a 7 mois et 3 semaines.

  • Créateur
    Sujet
  • #49740
    Avatar
    Mia
    Participant

    Bonjour à tous :bye:

    Je m’adresse plus particulièrement à Grey Cat, euhhh Pink Cat d’après ce que laisse sous-entendre AZAMOS bg

    Il m’avait conseillé l’extension Open Referer Control pour Firefox, que j’ai utilisée telle que configurée par défaut, pour la bonne raison que mon anglais étant ce qu’il est, je n’ai pas compris grand chose aux réglages.

    Puis j’ai lu sur un article,  sur Assiste me semble-t-il, qui expliquait un peu les choses et j’ai fait des modifications.
    Ma mémoire étant aussi défaillante que mon anglais, j’ai eu vite fait d’oublier avoir fait ces réglages (pourtant je note les modifs que j’effectue,  j’ai du oublier bg ).

    Bref, ça fait des semaines que je galère avec Goopics qui ne veux plus accepter mes images en m’envoyant ce message d’erreur : Formulaire envoyé depuis une page invalide.
    Pareil avec Sospc.name, quand je veux envoyer un commentaire, je suis systématiquement renvoyée sur la page de vente de post-it !
    Rien remarqué pour les autres sites. Ah si, celui de LibreOffice bien sûr :whistle:

    Je me suis donc crée un nouveau profil, et il fonctionne correctement avec ces 2 sites
    Je n’ai pas voulu supprimer mon ancien profil avant d’avoir trouvé le coupable.
    Et j’ai fini par mettre la main dessus ce matin en essayant de me connecter au site Libreoffice, qui lui m’a envoyé un message explicite :

    Interdit (403)
    La vérification CSRF a échoué. La requête a été interrompue.
    Vous voyez ce message parce que ce site HTTPS exige que le navigateur Web envoie un en-tête « Referer », ce qu’il n’a pas fait. Cet en-tête est exigé pour des raisons de sécurité, afin de s’assurer que le navigateur n’ait pas été piraté par un intervenant externe.
    Si vous avez désactivé l’envoi des en-têtes « Referer » par votre navigateur, veuillez les réactiver, au moins pour ce site ou pour les connexions HTTPS, ou encore pour les requêtes de même origine (« same-origin »).

    Je me suis enfin rappelée être allée modifier les réglages de Open Referer Control. J’y suis retournée en ajoutant ces 2 sites posant problème en exception, d’abord en récupérant leur adresse avec le https. Toujours pas !
    Vu que le champ vide commence par http, j’ai aussi essayé en enlevant le « s », mais les 2 sites continuent à bloquer.

    Ça ne fonction que si je repasse tout en normal
    edit : j’avais choisi Block à la rubrique « default referer for all other sites »

    Comment gérer les exceptions ?
    Et à quoi sert, que veut dire en bas de page : Load your site filter from Google / Mozilla Cloud sync (if you use multiples devices or reinstalled Referer Control)
    Car oui j’utilise la synchro de Mozilla sur de multiples devices…

    Merci d’avance ;-)

    Image

15 réponses de 1 à 15 (sur un total de 28)
  • Auteur
    Réponses
  • #49745
    Avatar
    Grey cat
    Participant

    Hello Mia

    Pour moi pas de probleme , il faut bien mettre sur Normal et desactiver ( passe en gris : to , from ,3rd )

    #49748
    Avatar
    Grey cat
    Participant

    Load your site filter from Google / Mozilla Cloud sync (if you use multiples devices or reinstalled Referer Control)

    C’est un message pour indiquer que tu peux récupérer les filtres de chrome et Firefox que tu as défini si tu as un compte associé avec ces navigateurs

    #49749
    Avatar
    Grey cat
    Participant

    #49750
    Avatar
    Grey cat
    Participant

     

    Attachments:
    #49752
    Avatar
    Grey cat
    Participant

    Pareil avec Sospc.name, quand je veux envoyer un commentaire, je suis systématiquement renvoyée sur la page de vente de post-it !

    Ca c’est un coup de Christophe pour te forcer à acheter !! mdrmdr bg

    pjs

    #49753
    Avatar
    Grey cat
    Participant

    sinon tu supprimes les sites qui bloquent avec la croix rouge devant , pas besoin de blocage pour SOSPC

    #49754
    Avatar
    Mia
    Participant

    Merci chat rose,

    Mais ça reste assez confus tout de même :scratch:

    Parce-que j’avais utilisé un traducteur, et ça n’est pas du tout ce que j’avais compris :

    Vous pouvez paramétrer l’envoi du référent sur une base par site.
    Chaque filtre est livré avec quatre options :
    to          Si vous ne voulez pas que ce site sache d’où vous venez.
    from    Pour cacher que vous êtes originaire de ce site.
    3rd       Seules les demandes de tiers sont filtrées.
    google.com demandant google.com/calendrier → demande de première partie
    google.com demandant bing.com → demande de tiers
    google.com demandant maps.google.com → demande d’un tiers
    RegEx  Interprète votre filtre comme une expression régulière. Pour les utilisateurs avancés.

    Il y a trois options de parrainage :
    Normal ne changez pas de référent – utilisez ceci pour mettre les sites en liste blanche lorsque vous utilisez l’action par défaut
    Configurez un référant personnalisé pour envoyer
    Bloquer n’envoie pas de référant du tout ce que j’avais choisi quand ça ne fonctionnait plus pour certains sites

    Vous pouvez utiliser * dans un filtre de site comme joker (si RegEx est désactivé).
    Attention : http://google.com ne correspond pas à http://www.google.com (et vice versa).
    Si vous voulez faire correspondre tous les sous-domaines, utilisez google.com (en omettant http://) ou utilisez un astérisque http://*google.com.
    Les filtres de site sont exécutés de bas en haut – le premier coup gagne.

    Je comprends que Normal ne change pas de référent, et qu’il faut ajouter les sites auxquels on souhaite dissimuler le référent :unsure:

    Et en désactivant To , tu ne souhaites pas dissimuler ta provenance,
    et en désactivant From, tu ne souhaite pas dissimuler que tu viens de ce site.

    Image

    #49755
    Avatar
    Mia
    Participant

    On a posté en même temps ;-)

    Ca c’est un coup de Christophe pour te forcer à acheter !! mdrmdr bg

    C’est bien ce que je me disais bg

    sinon tu supprimes les sites qui bloquent avec la croix rouge devant , pas besoin de blocage pour SOSPC

    C’est moi qui ai rajouté ces 2 lignes tout à l’heure en croyant que c’était la façon de les débloquer, mais à quand ça ne fonctionnait pas tous ces derniers jours, il n’y avait pas ces lignes, c’était juste comme ça :

    Image

    #49756
    Avatar
    Grey cat
    Participant

    A mon avis tu te compliques la vie pour rien , il suffit de ne pas appliquer le blocage aux sites qui te posent des problèmes en les supprimant de la liste :yahoo:

    Attachments:
    #49758
    Avatar
    Grey cat
    Participant

    C’est moi qui ai rajouté ces 2 lignes tout à l’heure en croyant que c’était la façon de les débloquer, mais à quand ça ne fonctionnait pas tous ces derniers jours, il n’y avait pas ces lignes, c’était juste comme ça :

    si il n’y avait pas les sites dans le blocage ce n’est pas lui en cause , a mon avis !

    #49759
    Avatar
    Grey cat
    Participant

    Mes réglages et ca marche bien avec !

     

    Attachments:
    #49761
    Avatar
    Mia
    Participant

    Malgré toute la peine que tu te donnes, je continue à nager lamentablement :wacko:

    Je fais des essais depuis tout à l’heure, avec GooPics seulement, car pour Sospc.name il faudrait que j’envoie un message en test à chaque fois, je ne sais pas si Christophe apprécierait beaucoup bg

    Avec le forum sospc, je n’ai jamais eu de soucis.

    Dans « default referer for all other sites » tu es bien sur Block ?

    Parce que tant que je suis sur Block, j’ai beau ajouter les exceptions exactement comme sur tes captures, ça ne veut pas.

    Et si je mets Normal dans « default referer pour tous les autres sites », je peux tout faire, même en mettant Block sur la ligne, ça passe  :wacko:

    Bon , j’arrête de me prendre le chou, et le tiens aussi par la même occasion, et je laisse sur normal, sans site filtré, comme c’était avant, mais ça me défrise de ne pas comprendre, pas grave, j’aime bien les brushings :yahoo: pjs

    Image

    #49762
    Avatar
    Grey cat
    Participant

    Pour les messages forum SOSPC pas de probleme , par contre en effet si je veux mettre un message  pour un article je dois arrêter le blocage !

    pour goopics tu le mets sur normal et ca doit fonctionner !

    moi j’ajoute que les sites inconnus ou dont j’ai un doute en blocage

    #49763
    Avatar
    Mia
    Participant
    Grey cat wrote:
    moi j’ajoute que les sites inconnus ou dont j’ai un doute en blocage
    Donc tu est bien en Normal et non pas en Block pour les autres sites
    (default referer for all other sites, en bas), tout s’explique :yahoo:
    Grey cat wrote:
    pour goopics tu le mets sur normal et ca doit fonctionner !

    Ça fonctionne si et seulement si, « Default referer for all other sites » est sur Normal aussi ;-)

    Image

    #49764
    Avatar
    Grey cat
    Participant

    « Default referer for all other sites » est sur Normal aussi

    A ce moment là ça sert plus a rien car tout les sites retournent sur leur état originel ,en permettant de savoir de quel site tu viens !

    Donc tu est bien en Normal et non pas en Block pour les autres sites

    Non , regarde ma capture d’écran des réglages et tu verras que je fais des réglages block ou normal selon les sites

     

15 réponses de 1 à 15 (sur un total de 28)

Vous devez être connecté pour répondre à ce sujet.