PROJET DÉCOUVERTE LINUX EN "VRAI" [RESOLU]

Accueil Forums Linux. PROJET DÉCOUVERTE LINUX EN "VRAI" [RESOLU]

Mots-clés : 

Ce sujet a 44 réponses, 6 participants et a été mis à jour par Avatar AZAMOS, il y a 3 semaines et 6 jours.

  • Créateur
    Sujet
  • #54496
    Avatar
    O Live
    Participant

    Bonjour à toutes et tous,

    Je me permets ici d’ouvrir un nouveau sujet relatif à ma volonté de découvrir Linux suite à l’article: « La distribution SPARKYLINUX, par Didier » de la semaine dernière. Pour ce faire et suite à mes divers échanges avec @mia et @didier sur le sujet, le week-end dernier je me suis  donc fais une clé USB  LIVE avec « persistance » via  Lili. Pas de souci particulier hormis la mise en Français de l’interface pour laquelle j’ai dû m’y reprendre à plusieurs reprises; mais j’y suis finalement parvenu…

    Ceci dit, et après prise en compte de toutes les précieuses informations  qui m’ont été transmises par les mêmes « Linuxiens » compétents quant à cette « expérience », j’ai décidé de revoir mon projet à la « hausse » visant à « vivre » une expérience en « vrai » si j’ose dire. J’entends par cela le souhait de vivre une expérience « débridée », la « vraie vie » quoi ! Et sans les limites imposées par le Live si j’ai tout bien compris !

    Pour cela, je projette donc d’installer LInux sur un SSD tout neuf que je vais ajouter dans ma machine et uniquement dédié à Linux. A partir de cela et de ma config actuelle, 2 premières questions:

    1. Quelle capacité pour le SSD Linux ? 120 Go me semblent suffisant d’après ma « culture » actuelle du sujet; mais suis-je bien dans le vrai ? J’ai bien noté qu’il fallait y caser le système, le swap et les données personnelles sauf erreur de ma part. Ma machine dispose actuellement d’une RAM de 16 Go (proco Intel i7 4ème génération, taille du swap par la même occasion avec le SSD ?).

    2. Je suis actuellement en dual boot Windows 10 1909 x64 (redondance par « sécurité ») sur 2 SSD distincts, dual boot configuré avec Easy BCD, aussi je me demande si je puis ajouter simplement une 3ème entrée sur le nouveau SSD Linux dans ce dernier et comment ? L’idée étant d’accèder à Linux par un simple clic sur le boot souhaité au démarrage du PC. @azamos si tu passes par ici, Merci par avance de « m’éclairer » …

    Dernière question pour l’heure: Quelle ISO de Linux Mint vais-je chercher actuellement visant à la graver sur un DVD pour l’install ? Dernière remarque enfin: Actuellement très occupé professionnellement, moins de temps forcément pour mes « loisirs » informatiques; aussi un grand Merci à Monsieur l’administrateur de me laisser le temps de répondre à ce sujet dès que mon temps libre me le permet…

    Merci par avance de votre précieuse collaboration,

    O Live.

     

    Au milieu de la difficulté se trouve l'opportunité ...

15 réponses de 16 à 30 (sur un total de 44)
  • Auteur
    Réponses
  • #55827
    Avatar
    O Live
    Participant

    Bonsoir AZAMOS, Bonsoir Darksky, Bonsoir à toutes et tous,

    Petit compte-rendu de l’install Linux Mint 19.3 Cinnamon effectuée hier soir (la livraison du SSD ayant été retardée) :

    1. Préalablement, reconfiguration physique des ports SATA pour laisser la place au SSD Linux sur le premier port et donc dans l’ordre actuellement : SSD Linux, SSD Windows 10-1 (disque d’amorçage du dualboot Windows avec easyBCD), SSD Windows 10-2, HDD Données 1, HDD Données 2, et enfin Lecteur/graveur DVD.

    2. Test de reconnaissance du matériel : OK.

    3. Déconnexion des 2 SSD Windows 10, connexion clé USB d’install Linux Mint, désactivation du Sécure Boot et démarrage sur cette dernière : OK.

    4. Installation Linux Mint (option « Effacer le disque et installer Linux Mint ») : OK.

    5. Redémarrage pour Linux : OK.

    6. Arrêt pour reconnexion des 2 SSD Windows 10, Démarrage avec affichage du « menu » Grub avec en plus les 2 instances Windows, choix Linux et maj du grub sudo update-grub.

    7. Arrêt puis démarrage en vue de tester la première instance Windows 10…et là « problème » : plus de Grub, affichage seul du menu dualboot Windows comme avant. Problème résolu en entrant dans le BIOS pour indiquer le SSD Linux en première priorité de démarrage.

    8 Redémarrage : OK avec affichage du « menu » Grub et avec les 2 instances Windows. Il me reste maintenant à créer une partition NTFS sur le SSD Linux Mint pour l’échange avec Windows.

     

    A partir de là, et d’un point de vue fonctionnement système, ça semble « tourner » correctement :good: (Linux démarre comme une balle de fusil, idem les temps BIOS Windows n’ont pas bougé d’un dixième de seconde); cependant, quelques observations brutes pour l’heure :

    • Durant mes tests de démarrages et redémarrages, il m’a fallu à 4 ou 5 reprises resynchroniser l’heure de l’une ou l’autre instance Windows qui retardait de 2 heures …En lien avec le fuseau horaire sûrement mais je ne parviens pas bien à me l’expliquer pour le moment, les mêmes fuseaux étant configurés dans Linux & Windows…
    • Si je veux entrer dans la seconde instance Windows 10, obligé de « passer » 2 fois dans le Grub si j’ose dire pour y accéder, je m’explique : Sélection du boot Windows dans le Grub au démarrage, ensuite affichage du menu dualboot Windows, sélection de la seconde instance Windows, ensuite affichage de nouveau du Grub, ensuite sélection de nouveau du boot Windows dans ce dernier pour enfin accéder directement au Windows 10 de cette instance. Ma réflexion sur ce point m’amène à penser que c’est tout à fait normal finalement, me disant que je suis en fait en présence de 2 dualboot « imbriqués » en quelques sorte. Avec 2 SSD d’amorçage, Linux pour l’un avec le Grub écrit dans son EFI sur son disque, Windows 10-1 pour le second avec le BCD écrit dans son EFI sur son disque, et qui lui-même gère le démarrage du troisième SSD Windows 10-2… J’ai bon ou j’ai tout faux ? Dans ce contexte, Grub me propose alors de sélectionner le second SSD Windows 10-2 pour confirmer.
    • A chaque démarrage de Linux, j’ai une fenêtre « ouvrir gestionnaire pilote »/une histoire d’absence d’accélération matérielle qui s’affiche m’invitant à sélectionner le meilleur pilote alors que le pilote recommandé est déjà installé ? J’ai une carte NVIDIA GTX 760 192 bits pourtant bien reconnue par Linux, parfaitement à jour dans Windows en tout cas, que je sollicite pas mal pour traiter de la vidéo 1920 x 1080 et avec laquelle je n’ai jamais rencontré le moindre problème… :wacko:

    Voilà donc les nouvelles  pour le moment, et j’en profite pour vous remercier encore et toujours de vos précieux conseils Mh . J’ai d’autres questions  à venir évidemment, que je me note au fil de ma découverte ce nouvel environnement un peu « space » qui suscite toute ma curiosité … :mail:

    Bien à vous :bye: ,

    O Live.

    Au milieu de la difficulté se trouve l'opportunité ...

    #55828
    Avatar
    AZAMOS
    Admin bbPress

    Hello O Live, :bye:

    Bon, dans l’ensemble cela s’est bien passé. :good:

    Pour le souci de différence d’heure : https://www.numetopia.fr/dual-boot-corriger-difference-heure-windows-linux/

    Pour précision sur le lien du dessus, tu as le choix de faire l’opération soi sur Linux, soi sur Windows… et pas sur les 2, hein. ;-)

    En ce qui concerne ce « multi-grub » lors du choix du second Windows, bien que n’étant pas sûr, ton analyse me semble bonne sur l’origine de ce (mini) bug.

    Pour l’histoire de ta carte graphique, remet le pilote « Linux », ceux de NVidia sont assez pourris, preuve en est que cela plante ton Cinnamon arrivé sur le Bureau. Pour expérience, j’ai testé avec le pilote « made in NVidia » vs. le pilote « Made in Linux » : zéro différence. :whistle: …. J’ignore pourquoi l’équipe de Mint continue à mettre « Recommandé » derrière celui de NVidia alors qu’il est connu que cela amène plus de pb que de bien… :wacko: :scratch:

    Qui cherche trouve, mais encore faut-il chercher au bon endroit !

    Image

    JE NE DONNE PLUS D'AIDE SUR LES PC SOUS WINDOWS 10

    #55833
    Avatar
    O Live
    Participant

    Re AZAMOS,

    Merci bien pour le lien concernant l’heure, je comprends mieux effectivement ! De ton avis et compte-tenu de ma config, tu corrigerais de préférence dans Linux ou dans Windows (perso, j’ai envie de le faire sous Linux) ? Concernant l’histoire du pilote graphique, de mémoire, dans Linux, il me me propose 5 ou 6 pilotes NVIDIA, et un seul qualifié de « générique » Linux. J’installe ce dernier à ton avis ?

    Merci bien AZAMOS et bonne soirée !

    Au milieu de la difficulté se trouve l'opportunité ...

    #55834
    Avatar
    AZAMOS
    Admin bbPress

    C’est avec plaisir, :-)

    Et bien vu que le tuto est assez clair, autant le faire sous Linux : ainsi tu commenceras à t’habituer à manipuler un peu sous ce système : « c’est en forgeant que l’on devient forgeron » comme dit l’adage. :-)

    De mon expérience j’ai toujours rencontré des difficultés avec les pilotes natifs Nvidia. Donc je serai d’avis de partir sur le pilote « Linux » ; après à toi de voir si tu veux faire des expériences…. mais je veux pas de procès si tu plantes tout ! bg bg bg

    Qui cherche trouve, mais encore faut-il chercher au bon endroit !

    Image

    JE NE DONNE PLUS D'AIDE SUR LES PC SOUS WINDOWS 10

    #55836
    Avatar
    O Live
    Participant

    Re AZAMOS,

    C’est exactement ma façon de penser :-) ! Pour apprendre, quoi de mieux au final que de mettre les mains dans le cambouis ? La meilleure école, non ? jnse

    Merci encore ! :bye:

    Au milieu de la difficulté se trouve l'opportunité ...

    #55840
    Avatar
    Darksky
    Participant

    :bye: O Live,

    Merci pour ton retour sur cette installation :good:

    Très heureux de constater, en tout cas, que cela fonctionne :-)

    Concernant le pilote de la carte graphique, j’utilise personnellement le pilote recommandé (actuellement le nvidia-driver-440), et je possède une GTX970.

    Après c’est souvent du cas par cas. J’avoue ne jamais avoir eu de réels soucis avec lui, d’autres comme Azamos en ont eu et utilisent avec succès le pilote « nouveau ». Ça dépend vraiment d’un ensemble je dirais. Le mieux sera toujours ce qui fonctionne pour toi ;-)

    Pour le reste, j’ai fait la manip sur l’heure sur Linux aussi (plus rapide en fait ^^ clairement par fainéantise), et au niveau du dualboot comme vous je pense que c’est « à cause » du précédent multiboot que tu as ce « problème ».

    Mais globalement, es-tu content de ton expérience et surtout de ta distribution?

     

    • Cette réponse a été modifiée le il y a 1 mois et 1 semaine par Avatar Darksky.

    - "Il ne savaient pas que c'était impossible, alors ils l'ont fait" - M.Twain

    Image

    #55856
    Avatar
    O Live
    Participant

    Salut à toi Darksky !

    Oui ! Content de démarrer cette nouvelle expérience Linux Mint :-) et d’avoir pu faire cette config qui plus est !

    Maintenant, il faut évidemment que rentre dans ce système curieux de comprendre sa « philosophie » et sa structure. Exit mes « réflexes » Windows, ça ne marche pas comme ça nnn !!! En même temps ce serait trop simple et pas très excitant non ? Dès que je serai plus à l’aise avec les « fondamentaux », je me mettrai en quête de trouver tous les logs qui vont bien visant à disposer d’outils équivalents nécessaires à mes tâches quotidiennes sur Windows.

    Bien à toi et Bon week-end !

     

    Au milieu de la difficulté se trouve l'opportunité ...

    #55884
    Avatar
    O Live
    Participant

    Bonjour AZAMOS, Darksky, et à toutes et tous,

    Bon! Linux a donc décidé de me « contrarier » d’emblée jnse bg ! Mais rien de tel  pour m’exciter à vrai dire, je fais évidemment allusion à mon « cerveau » hein ! bg

    1. Correction du « décalage horaire »: J’envoie la commande qui va bien dans Linux pour passer en heure locale et la console me répond grosso modo que ce n’est pas bon, je recommence donc et même réponse. Sauf que quand j’envoie la commande de vérification la console me confirme alors que je suis déjà en heure locale ? Ha bon! J’avais cru comprendre que Linux était en UTC par défaut… « Heureux » de l’apprendre donc :-) … Sauf que je viens de rebooter sur Windows 10 qui m’affiche … 2 heures de moins ??? Je viens donc de resynchroniser l’heure Windows dans les paramètres; mais quelque chose m’échappe évidemment ! bgh
    2. Concernant le pilote de ma carte graphique NVIDIA: Au démarrage de Linux ce matin, toujours cette fenêtre qui me dit que mon système tourne sans accélération matérielle, que mon système risque d’être instable et que mon proco va « bouffer » beaucoup de ressources. On me propose alors d’ouvrir le gestionnaire de pilotes, et là je sélectionne à ce moment le pilote générique open source Linux « nouveau » que j’installe ayant déjà testé tous les autres sans succès… Sauf qu’après redémarrage, non seulement je retrouve cette fenêtre qui me dit toujours la même chose et me propose toujours d’ouvrir le gestionnaire de pilotes. J’ouvre alors ce dernier et …je tombe sur une fenêtre vide sans plus aucune proposition ? J’insulte donc Linux en continu mais visiblement cela ne sert à rien bgh bg ! Plus sérieusement et d’après mes recherches, ce n’est pas une légende que Mint a visiblement un problème récurrent  avec les cartes graphiques NVIDIA, j’ai vu qu’il y avait pléthore de cas comme le mien et cela ne date pas d’hier. La question que je me pose maintenant: Comment puis-je accéder de nouveau à un choix de drivers graphiques tout en ayant bien compris me semble-t-il qu’il était fortement déconseillé d’installer « en direct » un pilote NVIDIA sous peine de mettre le « bordel » total dans Linux Mint… Enfin quant à cet avertissement de risque de consommation excessive de ressources proco (Intel I7 / 3,1 Ghz), j’observe effectivement que ce dernier est à 15% de moyenne  au repos dans Linux (je n’ai encore rien installé); alors que je suis à 1% dans le même contexte sous Windows avec une consommation de  RAM pratiquement identique. Linux Mint c’est à peu près de base 10 Go d’occupation sur un disque, mes Windows c’est à peu près 60 Go d’occupation avec 3 ou 4 logiciels de traitement photos & vidéos « très lourd » de réputation…

    Depuis toujours, je suis convaincu qu’il n’existe pas de problème sans solution; ceci dit à la lecture de pas mal d’expériences, force est de constater quand même que pour beaucoup de « Windowsiens convaincus »,  il est compréhensible qu’ils aient abandonné très vite suite à ces « bug » récurrents de « compatibilité » qui ne sont plus une légende… Aussi, je veux et je me dois donc  de « dépoiler » ce système qui doit répondre à mes principaux besoins quotidiens ! Je me dis que seule la réussite de mon expérience personnelle eu égard à mes besoins me donnera véritablement  légitimité à juger Linux en notre époque …

    Bon Dimanche à vous !

    O Live.

    Au milieu de la difficulté se trouve l'opportunité ...

    #55891
    Avatar
    Darksky
    Participant

    :bye:

    1. Pour corriger l’heure, n’oublie pas d’exécuter la commande en administrateur.. ;-)

    sudo timedatectl set-local-rtc 1

    2. Il semblerait bien qu’un problème soit survenu avec les pilotes en effet. Il est possible que tu n’aies pas une configuration complète de l’ensemble.

    Est-ce que tu pourrais éventuellement donner le retour de ces 2 commandes (juste les lancer, pas besoin d’être en « sudo » ici):

    • D’abord nous donner le retour de:

    inxi -Sr

    • Et ensuite de:

    apt search ?broken

    On pourra peut-être trouver une piste :yes:

    • Cette réponse a été modifiée le il y a 1 mois et 1 semaine par Avatar Darksky.

    - "Il ne savaient pas que c'était impossible, alors ils l'ont fait" - M.Twain

    Image

    #55895
    Avatar
    O Live
    Participant

    Salut à toi Darksky et tout d’abord Merci de ton retour,

    Avant de prendre connaissance de ta proposition, je viens à l’instant de faire la commande suivante:

    sudo apt install nvidia-prime-applet

    Ce qui me permet à priori de retrouver le gestionnaire de pilotes d’origine me proposant de nouveau de sélectionner parmi 4 pilotes NVIDIA et le « nouveau » open-source :yahoo: , le pilote recommandé étant un NVIDIA 440.59. Par la même occasion et concernant la correction de l’heure Linux, j’ai ensuite envoyé de nouveau la commande qui va bien avec « sudo » et le résultat me semble OK :yahoo: .

    Le pilote actuellement sélectionné est le nouveau « open-source » conformément à ma sélection d’hier pensant que je n’aurai plus cette fenêtre d’avertissement au démarrage de Mint m’indiquant que je « tourne » sans accélération matérielle et que le proco risque de « bouffer » un max de ressources…

    Dans ce contexte, la réponse à la commande inxi -Sr est la suivante:

    System:
    Host: olive-G10AC Kernel: 5.3.0-53-generic x86_64 bits: 64
    Desktop: Cinnamon 4.4.8 Distro: Linux Mint 19.3 Tricia
    Repos:
    No active apt repos in: /etc/apt/sources.list
    Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list
    1: deb http://packages.linuxmint.com tricia main upstream import backport #id:linuxmint_main
    2: deb http://archive.ubuntu.com/ubuntu bionic main restricted universe multiverse
    3: deb http://archive.ubuntu.com/ubuntu bionic-updates main restricted universe multiverse
    4: deb http://archive.ubuntu.com/ubuntu bionic-backports main restricted universe multiverse
    5: deb http://security.ubuntu.com/ubuntu/ bionic-security main restricted universe multiverse
    6: deb http://archive.canonical.com/ubuntu/ bionic partner

    La réponse à la commande apt search ?broken est:

    « RIEN DU TOUT » !!! c’est ce que je lis en tout cas ! ;-)

    J’écris actuellement avec Chromium installé ce matin :yahoo: et en Français (je commence à « toucher » bg ); mais inutile de te dire que la résolution graphique me semble bien « dégueulasse » / 1920×1080 sous Windows ! nnn

    Merci encore et toujours de ton support Darksky ! Putain ! Qui a dit que c’était « chaud » Linux ? Il m’a quand même fallu 1 heure pour trouver la soluce pour mettre Chromium en Français, quand tu sais que tu « pirates » des log à 500 balles sous Win en 5 minutes ! bg jnse MAIS je débarque fraîchement et pense donc que ça doit être normal ! Rassure moi ! :yes:

    Bonne journée à toi !

    Au milieu de la difficulté se trouve l'opportunité ...

    #55896
    Avatar
    O Live
    Participant

    Re Darksy,

    Pour info, voici en PJ, ce que le gestionnaire de pilotes me propose à nouveau à l’issue de ma commande: sudo apt install nvidia-prime-applet …

     

    Au milieu de la difficulté se trouve l'opportunité ...

    #55901
    Avatar
    Didier
    Participant

    Bonjour O Live

    J’écris actuellement avec Chromium installé ce matin

    Concernant Google Chrome pour Linux, tu peux le télécharger sur le site:

    choisir le fichier deb suivant :

    le décompresser sous Mint avec l’utilitaire gdebi (installé par défaut ) …….

    Pour franciser un logiciel sous Linux rechercher par l‘outil Synaptic, google fr par exemple, tu trouveras le paquet correspondant en principe !

    Cdlt  FWBL

    DGS

    #55904
    Avatar
    AZAMOS
    Admin bbPress

    Re, et salut à tous ! :bye:

    P’tite question : ton écran est connecté comment ? En VGA, HDMI, DVI ?

    Et au cas où : tu n’aurais pas 2 câbles vidéos connectés en même temps sur l’écran ?

    Qui cherche trouve, mais encore faut-il chercher au bon endroit !

    Image

    JE NE DONNE PLUS D'AIDE SUR LES PC SOUS WINDOWS 10

    #55907
    Avatar
    O Live
    Participant

    Salut à toi AZAMOS, Salut Didier,

    Je passe rapidement pour t’indiquer qu’il est en HDMI sur la GTX720. Tout à l’heure, je pense que je tenterai de nouveau pour voir l’install du pilote NVIDIA recommandé comme à l’origine. Ceci dit, je n’y crois pas trop compte tenu de l’armada de problèmes semblables récurrents observés sur les forums de la part de possesseurs de GTX NVIDIA de la même génération… Mint semble en effet avoir pas mal de « problèmes » de compatibilité avec ces produits pourtant très largement répandus; mais j’ai découvert aussi le grand « différend » de Monsieur LINUX avec NVIDIA bg ! Ceci expliquant peut-être en partie cela?

    Encore Merci à vous ! Je creuse, je creuse … ou je jnse bg

    Au milieu de la difficulté se trouve l'opportunité ...

    #55910
    Avatar
    O Live
    Participant

    Re AZAMOS, Darksky et Didier,

    CHANGEMENT DE PROGRAMME !!! Je ne comprends pas tout là tout de suite; mais je vais tâcher de comprendre ! Figurez-vous que je viens simplement de redémarrer avant de partir… ET J’AI NON SEULEMENT MA RESOLUTION 1920X1080, ET PLUS CETTE FENETRE DU GESTIONNAIRE DE PILOTES AU DEMARRAGE !  :yahoo:

    Qu’ai-je donc fait ? RIEN à ma connaissance; hormis cette commande ce matin: sudo apt install nvidia-prime-applet     qui m’a permis de retrouver le gestionnaire de pilotes me proposant à nouveau un choix de pilotes graphiques alors qu’il était désespérément vide depuis hier !!! Cela viendrait-il donc de cette commande ? Pour info, je viens de vérifier à nouveau et je suis sur le pilote « nouveau » open-source, et non pas sur un pilote NVIDIA. Résolution également OK pour CHROMIUM.

    Je suis sur le c… mais trop heureux ! :yahoo: :good:   Pourvu que ça dure !

    Au milieu de la difficulté se trouve l'opportunité ...

15 réponses de 16 à 30 (sur un total de 44)

Vous devez être connecté pour répondre à ce sujet.