Pilote Nvidia et Linux Mint: quand la mise à jour provoque une régression

Accueil Forums Linux. Pilote Nvidia et Linux Mint: quand la mise à jour provoque une régression

  • Ce sujet contient 10 réponses, 6 participants et a été mis à jour pour la dernière fois par Mathieu, le il y a 3 semaines.
  • Créateur
    Sujet
  • #65286
    D a r k s k y
    Participant

    :bye:

    Je ne sais pas si vous avez eu le cas, mais voici ce qui m'est arrivé dernièrement, et la solution bien sur :good:

    Je suis sur Linux Mint (20.2) Cinnamon. J'ai une carte graphique Nvidia (GTX 970). Dernièrement, j'ai voulu mettre à jour le pilote graphique via le gestionnaire de pilote propriétaire.

    Je choisi donc la version recommandée, et une redémarrage plus tard... patatra! Une fenêtre me signalait que mon système s'exécutait sans accélération matérielle et que cela pouvait entraîner une consommation excessive de l'usage du CPU.

    J'ai tout essayé, à part utiliser le pilote libre "Nouveau", rien ne fonctionnait. Ce pilote est très bien, mais il peut vite devenir bloquant pour qui aurait besoin de toute la puissance de sa carte graphique.

    Voici la solution, donc, pour pouvoir utiliser le pilote Nvidia:

    • Mettre à jour le pilote, redémarrer. Vous aurez droit au message cité plus haut ainsi qu'à un affichage "tout foutu".
    • Ouvrir un terminal, et y taper:

    xed admin:///etc/modules

    Cela va ouvrir une fenêtre de l'éditeur de texte. Vous devrez mettre votre mot de passe administrateur (root) car il s'ouvre pour modifier des fichiers de configurations.

    • ajouter dans la fenêtre qui s'est ouverte, après les phrases commençant par # :

    nvidia
    nvidia-drm
    nvidia-modeset

    voici ce que cela doit donner:

    • Cliquer sur fichier, et enregistrez.

    Redémarrez, et normalement, tout sera rentré dans l'ordre :yes:

    Pour la petite histoire, j'ai trouvé la soluce sur le site de Linux Mint, et l'explication viendrait du fait qu'en ajoutant ces lignes, on laisse plus de temps au système pour charger les pilotes avant qu'il ne démarre. En gros, il démarrant trop vite que pour prendre en compte les pilotes slt

    Voila, si jamais cela peut vous aider, je l'ai posé ici ;-)

     

     

    • Ce sujet a été modifié le il y a 1 mois et 3 semaines par D a r k s k y.
    • Ce sujet a été modifié le il y a 1 mois et 3 semaines par D a r k s k y.

    - "Il ne savaient pas que c'était impossible, alors ils l'ont fait" - M.Twain

    Image

10 réponses de 1 à 10 (sur un total de 10)
  • Auteur
    Réponses
  • #65289
    AZAMOS
    Maître des clés

    Salut Darksky, :bye:

    J'ai déjà rencontré ce souci à diverses reprises, mais cela fait au moins 6 ou 8 mois que je ne l'ai plus eu.

    Merci pour l'astuce qui me servira bien si cela devait m'arriver. :good:

    Qui cherche trouve, mais encore faut-il chercher au bon endroit !

    Image

    JE NE DONNE PLUS D'AIDE SUR LES PC SOUS WINDOWS 10

    #65290
    E r m o
    Participant

    Hello Darksy

    Merci pour le tuyau, il pourrait bien servir un jour ou l'autre.

    Mint et Nvidia, j'ai l'impression que c'est pas vraiment le grand amour. Je suis sous Mint 20 xfce + Nvidia gtx 1660 Ti : galère à l'installation  pour trouver le pilote qui ne plante pas tout et nécessité ensuite de régler la luminosité par le terminal (automatisé au démarrage heureusement) sinon elle reste au max, bonjour les yeux :-(   et comme je triture des photos...

    Par la suite plantage complet lors d'une mise à jour y compris Grub invisible au démarrage, le désastre. Merci Timeshift qui m'a sauvé la mise :yes:

    Depuis je refuse systématiquement les màj Nvidia et ça tourne OK mais c'est gonflant. J'ai pas le temps de m'occuper de ça en ce moment mais je tenterai peut-être POP OS, il paraît que c'est nickel avec les pilotes Nvidia

    :bye:

     

    #65292
    M i a
    Participant

    Coucou Darksky,

    Merci pour l'info, ça peut être utile un jour ou l'autre ;-)

    J'ai déjà eu ce message disant que le système s'exécutait sans accélération matérielle en VM mais pas avec mon système installé.

    J'ai lu à plusieurs reprise sur le forum FFLM que le problème ne se produit qu'avec Cinnamon :unsure:

    je tenterai peut-être POP OS

    Si c'est la cas, et que tu as le temps, dis-nous ce que tu penses de cette distribution, avec quelques captures pour avoir une idée de son apparence ça serait sympa :yes:

    Bonne journée à tous :bye:

    Image

    #65293
    D a r k s k y
    Participant

    Salut à vous :bye:   ,

    @azamos: Oui, en fait j'ai eu ce problème lors de mon passage à Mint 20.2, mais comme je n'avais pas le temps de me pencher dessus j'avais remis le pilote "Nouveau". Ici, j'ai enfin pu m'atteler à trouver une solution.

    @Ermo: Je n'ai heureusement pas eu autant de problèmes que toi.. Il semble cependant en effet que les cartes AMD soient mieux prises en charge, et que les pilotes proprios Nvidia soient vraiment mal fichus. Nvidia est vraiment bon niveau Windows, mais sur Linux, AMD est souvent plébiscité, et je comprend pourquoi.

    @Mia: En effet, Cinnamon a besoin d'une accélération graphique car il est "plus poussé" et demande plus de ressources. Je n'ai jamais testé avec un autre environnement par contre ;-)

     

    • Cette réponse a été modifiée le il y a 1 mois et 3 semaines par D a r k s k y.

    - "Il ne savaient pas que c'était impossible, alors ils l'ont fait" - M.Twain

    Image

    #65295
    E r m o
    Participant
    Bonjour tout le monde,

    dis-nous ce que tu penses de cette distribution, avec quelques captures pour avoir une idée de son apparence ça serait sympa

    Je n'y manquerai pas ... si Didier ne me double pas avant (un écran d'accueil avec un coucher de soleil devrait suffire à le décider bg ) vu que ça ne va pas être pour tout de suite. Il faudrait déjà que j'aie un accès décent à internet, Orange me promène depuis mon déménagement début Mars: je n'ai pas droit à l'ADSL bien qu'une le ligne téléphonique soit présente ... parce que je suis "éligible" à la fibre (c'est comme ça qu'ils disent ) mais comme ils ont un problème de branchement, toujours rien en vue  :wacko: . En attendant ils me prêtent une box  qui fait ce qu'elle peut, c'est pas comme eux qui n'en ont rien à battre et traînent à l'évidence au fil des sous-traitants bgh

    Le gag (qui  ne me fait pas mourir de rire) c'est qu'ils m'ont attribué un N° de fixe mais que je n'aurai accès à la ligne qu'avec le branchement de la fibre pett

    Nvidia est vraiment bon niveau Windows

    Mmmouais... C'est sans doute moi qui suis mauvais mais j'ai sur ma tour un Ryzen G et une carte Nvidia qui ont longtemps tourné de pair sans souci mais suite à une nième mise à jour de windows gros problème d'affichage sur les 2 écrans que j'utilise en étendu pour traiter mes photos. Faute de trouver une solution j'ai dû faire machine arrière. Là encore je reprendrai ça quand j'aurai du temps et une ligne internet. Après tout ça me va comme ça.

    :bye:

     

     

    #65296
    D i d i e r
    Participant

    Bonsoir à tous

    si Didier ne me double pas avant (un écran d'accueil avec un coucher de soleil devrait suffire à le décider

    Eh oui, j'accorde une importance toute particulière au design, aux wallpapers......tu l'as bien compris ! ;-)

    Concernant Pop OS, c'est basé sur l'environnement Gnome, faut aimer, je l'avais testé il y a quelque temps, rien d'extraordinaire. :unsure:

    Pour le moment , j'ai réinstallé Ubuntu Budgie, et l'ai relooké façon Mac, ça change de l'anémone bleue de Windows 11 bg

    Bon week-end

    FWBL DGS

    #65297
    E r m o
    Participant

    ça change de l'anémone bleue de Windows 11

    Salut Didier,

    Perso je verrais plus un polype intestinal chez un intoxiqué au bleu de méthylène qu'une anémone mais bon, à chacun sa poésie. Mon intérêt pour  Pop OS c'est uniquement parce qu'il se dit qu'il gère bien les cartes Nvidia

    :bye:

     

     

    #65299
    D i d i e r
    Participant

    Salut Ermo

     

    OK pour les pilotes NVIDIA

     

    Pour info, j'ai trouvé ceci sur le site de Korben

    https://korben.info/comment-installer-les-drivers-nvidia-sous-linux.html

    Bon we, et si tu installe POP Os, fais nous part de ton ressenti

    bon we  FWBL

    PS  beaucoup plus beau que le chou-fleur bleu windonze

     

    #65300
    E r m o
    Participant

    :good:

    Très intéressant ton lien, je garde, merci . Bon WE à toi aussi

    :bye:

     

    #65524
    Mathieu
    Participant

    Bonjour les amies, TCLM

    Merci pour cette solution fort efficaces et très fonctionnel j'ai eux justement le problème a plusieurs reprise cela ma justement fait désinstaller Linux mint au profit de Windows , mais ça y est j'ai passer le pas je suis Finalement sous linux Mint uniquement et cette solution et très simple et efficaces merci encore pour tous. :rose:

10 réponses de 1 à 10 (sur un total de 10)
  • Vous devez être connecté pour répondre à ce sujet.