AMD Ryzen Vega Graphique et noyau 5.3.0.53 : bug et solution

Accueil Forums Linux. AMD Ryzen Vega Graphique et noyau 5.3.0.53 : bug et solution

Ce sujet a 4 réponses, 2 participants et a été mis à jour par Avatar AZAMOS, il y a 1 mois et 1 semaine.

  • Créateur
    Sujet
  • #55822
    Avatar
    AZAMOS
    Admin bbPress

    Bonjour à tous, :)

    J’ai constaté ces derniers jours un bug concernant dans mon cas 2 processeurs AMD Ryzen 2200G (PC fixe) et un AMD Ryzen 3 3200u (PC portable).

    Ils ont en point commun :

    – chipset graphique intégré au processeur (Radeon Vega Graphic)
    – équipés de Linux Mint Cinnamon 64 bits

    2 (1 fixe et le portable) sont tout neufs, la seconde tour est récente de quelques mois à peine et faisait tourner Mint 19.2 puis 19.3 sans souci, maj faite régulièrement.

    Les bugs : suite à l’installation du noyau 5.3.0.53 =>
    – l’arrêt ne se fait pas ; l’écran s’éteint bien mais les ventilateurs ainsi que l’activité HDD/SSD sont toujours en fonction.
    – le « Redémarrage » ne se fait pas non plus, laissant sur un écran noir, le reste de la machine tournant encore.

    Solution :

    1) lancer le Grub au démarrage (pour rappel soit maintenir la touche Shift enfoncée au boot, soit juste après la disparition du logo du PC appuyer sur la touche « Echap« ).

    2) descendre sur « Options avancées pour Linux Mint 19.3 Cinnamon »

    3) descendre sur « Linux Mint Cinnamon, avec Linux 5.3.0.51 » (ou autre version selon votre cas) ; prendre la ligne SANS « (recovery mode) », c’est inutile.

    4) une fois arrivé sur le Bureau, lancer le « Gestionnaire de mises à jour« , puis aller dans « Vues » => « Noyaux Linux »

    5) cliquer sur le noyau 5.3.0.53 et sélectionner « Retirer« .

    6) Ceci fait, redémarrage du PC, et tout devrait bien se passer.

    7) à nouveau sur le Bureau, lancer une recherche de Maj sur le « Gestionnaire de mises à jour » ; le noyau 5.3.0.53 vous sera à nouveau proposé : faire un clique-droit dessus et sélectionner l’un des 2 choix « Ignorer cette mise à jour » ou « ignorer toutes les mises à jour futures pour ce paquet » (perso j’ai pris la seconde option).

    Et voilà ! :)

    Quelques trucs et réflexions en vrac :

    – ce bug ne s’est pas produit sur des PC équipés de processeurs Intel (testé sur 5 machines) ou sur Ryzen sans partie graphique (Ryzen 3 1300x et 7 2700x) ou AMD série A (A6 et A10), ces derniers ayant un chipset graphique différent.

    – à ce qu’il semble, ce sont donc les proco AMD avec un chipset graphique « Radeon Vega Graphic » qui sont touchés, sur fixe ou portable…

    J’attends vos retour à ce sujet.

    Qui cherche trouve, mais encore faut-il chercher au bon endroit !

    Image

    JE NE DONNE PLUS D'AIDE SUR LES PC SOUS WINDOWS 10

4 réponses de 1 à 4 (sur un total de 4)
  • Auteur
    Réponses
  • #55842
    Avatar
    Darksky
    Participant

    :bye: Aza,

    Il faudrait voir si cela a déjà été signalé, si pas ne pas hésiter à la faire.

    C’est ce qu’ils appellent des « régressions », c’est-à-dire des bugs qui ne se produisaient pas avant avec le matos, mais qui sont apparu avec le nouveau noyau. Dans ces cas-là, ils le signalent et déconseillent la mise à jour le temps qu’ils corrigent le truc.

    Perso je n’ai pas de matos AMD (ce sera pour ma prochaine machine TCLM   ) donc je ne peux t’en dire plus.

    - "Il ne savaient pas que c'était impossible, alors ils l'ont fait" - M.Twain

    Image

    #55843
    Avatar
    AZAMOS
    Admin bbPress

    Hello Darksky,

    J’ai remarqué ce bug il y a une dizaine de jour sur le PC d’un client. Je m’étais dis à ce moment là que c’était un cas isolé, lié à un mauvais paramétrage ou autre.

    Mais ces derniers jours j’ai rencontré le cas sur 3 autres PC, dont 1 hier juste après avoir posté l’info ici.

    Je n’ai trouvé nul part une discussion remontant ce souci… :unsure:

    Qui cherche trouve, mais encore faut-il chercher au bon endroit !

    Image

    JE NE DONNE PLUS D'AIDE SUR LES PC SOUS WINDOWS 10

    #55845
    Avatar
    AZAMOS
    Admin bbPress

    Re,

    Je viens d’envoyer un mail au support de Linux Mint pour remonter le souci. ;-)

    Qui cherche trouve, mais encore faut-il chercher au bon endroit !

    Image

    JE NE DONNE PLUS D'AIDE SUR LES PC SOUS WINDOWS 10

    #55851
    Avatar
    AZAMOS
    Admin bbPress

    Ça a pas traîné, à peine une heure après j’ai eu une réponse :

    Bonjour Frédéric,
    Merci. Les régressions au niveau du noyau sont en amont, même pas au niveau d’Ubuntu mais de l’equipe Linux (noyau) directement. Ca arrive assez souvent vu la cadence de développement. Espérons que ce sera vite corrigé.
    Regards,

    Clement Lefebvre
    Linux Mint

    Il y aurait l’un d’entre-vous ayant un AMD Ryzen avec Radeon Vega Graphic (ex : RYZEN 3200G ou autre) avec le noyau 5.3.0-53 et qui aurait (ou pas) le bug ?
    Car nul part je n’ai vu une discussion sur une autre distro (Ubuntu, Debian, Gentoo,…) en parlant…. d’ailleurs on dirait que je suis le seul à en parler.  Mais ce qui me rassure c’est que mon autre poste sur le forum francophone de Linux Mint a eu une remonté d’un membre ayant eu le même souci : https://forum-francophone-linuxmint.fr/viewtopic.php?f=33&t=15897&sid=7f0aabd4f34e835573976222861e0fb4

    Qui cherche trouve, mais encore faut-il chercher au bon endroit !

    Image

    JE NE DONNE PLUS D'AIDE SUR LES PC SOUS WINDOWS 10

4 réponses de 1 à 4 (sur un total de 4)

Vous devez être connecté pour répondre à ce sujet.